summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am109
1 files changed, 0 insertions, 109 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
deleted file mode 100644
index 925eaca..0000000
--- a/src/lib/Makefile.am
+++ /dev/null
@@ -1,109 +0,0 @@
-#
-# Copyright 2004,2005,2006,2008 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-#
-
-include $(top_srcdir)/Makefile.common
-
-SUBDIRS = decoder
-# Install this stuff so that it ends up as the gnuradio.howto module
-# This usually ends up at:
-# ${prefix}/lib/python${python_version}/site-packages/gnuradio
-
-ourpythondir = $(grpythondir)
-ourlibdir = $(grpyexecdir)
-
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
-# -I$(OPEN_BTS_INCLUDES)
-
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(SWIGGRFLAGS) $(WITH_SWIG_INCLUDES) \
- $(WITH_INCLUDES)
-
-ALL_IFILES = \
- $(LOCAL_IFILES) \
- $(NON_LOCAL_IFILES)
-
-NON_LOCAL_IFILES = \
- $(GNURADIO_CORE_INCLUDEDIR)/swig/gnuradio.i
-
-
-LOCAL_IFILES = \
- $(top_srcdir)/src/lib/gsm.i
-
-# These files are built by SWIG. The first is the C++ glue.
-# The second is the python wrapper that loads the _howto shared library
-# and knows how to call our extensions.
-
-BUILT_SOURCES = \
- gsm.cc \
- gsm.py
-
-# This gets howto.py installed in the right place
-ourpython_PYTHON = \
- gsm.py
-
-ourlib_LTLIBRARIES = _gsm.la
-
-lib_LTLIBRARIES = libgsmdemod.la
-
-# These are the source files that go into the shared library
-_gsm_la_SOURCES = \
- gsm.cc
-
-libgsmdemod_la_SOURCES = \
- gsm_receiver_cf.cc \
- gsm_receiver_config.cc \
- viterbi_detector.cc
-
-# magic flags
-_gsm_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
-
-# link the library against some comon swig runtime code and the
-# c++ standard library
-_gsm_la_LIBADD = \
- $(PYTHON_LDFLAGS) \
- libgsmdemod.la \
- -lstdc++ \
- $(DECODER_LA)
-
-#libgsmdemod_la_LIBADD =
-
-gsm.cc gsm.py: $(LOCAL_IFILES) $(ALL_IFILES)
- $(SWIG) $(SWIGPYTHONARGS) -module gsm -o gsm.cc $(LOCAL_IFILES)
-
-# These headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS = \
- gsm_receiver_cf.h \
- gsm_receiver_config.h
-
-noinst_HEADERS = \
- gsm_constants.h \
- viterbi_detector.h
-
-# These swig headers get installed in ${prefix}/include/gnuradio/swig
-swiginclude_HEADERS = \
- $(LOCAL_IFILES)
-
-
-MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
-
-# Don't distribute output of swig
-dist-hook:
- @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
- @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
personal git repositories of Harald Welte. Your mileage may vary