summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 6 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index e7d31c6..0d087f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,24 +1,18 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
-SUBDIRS = etc include src
-
-DEFAULT_AM_CFLAGS = -std=gnu99
+include $(top_srcdir)/Makefile.flags.am
-if ENABLE_WIN32
-SUBDIRS += win32
-LINKOPTS = -mno-cygwin
-AM_CFLAGS = $(DEFAULT_AM_CFLAGS) -mno-cygwin
-else
-LINKOPTS = -lusb
-AM_CFLAGS = $(DEFAULT_AM_CFLAGS)
-endif
+SUBDIRS = etc include src
if ENABLE_FIRMWARE
-AM_CFLAGS += -DLIBRFID_FIRMWARE
else
SUBDIRS += utils
endif
+if ENABLE_WIN32
+SUBDIRS += win32
+endif
+
EXTRA_DIST = LICENSING librfid.spec openct-cm5121-librfid.patch
$(OBJECTS): libtool
personal git repositories of Harald Welte. Your mileage may vary