summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..163c0ca
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,27 @@
+AC_PREREQ(2.53)
+AC_INIT(gsmd, 0.0.1, http://www.openmoko.org/)
+AM_INIT_AUTOMAKE()
+AC_CONFIG_SRCDIR(src/gsmd/gsmd.c)
+AM_CONFIG_HEADER(config.h)
+AM_MAINTAINER_MODE
+
+AC_ISC_POSIX
+AC_PROG_CC
+AC_STDC_HEADERS
+AC_PROG_LIBTOOL
+
+# base deps
+
+# output stuff
+AC_OUTPUT([
+Makefile
+libgsmd.pc
+src/Makefile
+src/gsmd/Makefile
+src/libgsmd/Makefile
+src/util/Makefile
+include/Makefile
+include/gsmd/Makefile
+include/libgsmd/Makefile
+])
+
personal git repositories of Harald Welte. Your mileage may vary