summaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
authorPiotr Krysik <perper@o2.pl>2009-04-07 12:47:18 +0200
committerPiotr Krysik <perper@o2.pl>2009-04-07 12:47:18 +0200
commit39a50c763240da578a05a6b651776804786d813a (patch)
tree2d67e1f9c64e08ac6dfc77355c47c8180ee6431a /config/Makefile.am
parent2b2d45f061a737203583def6907cb139ff553fab (diff)
Added files from gr-howto-write-a-block
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
new file mode 100644
index 0000000..0b82ea3
--- /dev/null
+++ b/config/Makefile.am
@@ -0,0 +1,68 @@
+#
+# Copyright 2001 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+# Install m4 macros in this directory
+m4datadir = $(datadir)/aclocal
+
+# List your m4 macros here
+m4macros = \
+ bnv_have_qt.m4 \
+ cppunit.m4 \
+ gr_boost.m4 \
+ gr_check_createfilemapping.m4 \
+ gr_check_usrp.m4 \
+ gr_check_mc4020.m4 \
+ gr_check_shm_open.m4 \
+ gr_doxygen.m4 \
+ gr_gprof.m4 \
+ gr_libgnuradio_core_extra_ldflags.m4 \
+ gr_no_undefined.m4 \
+ gr_omnithread.m4 \
+ gr_pwin32.m4 \
+ gr_python.m4 \
+ gr_require_mc4020.m4 \
+ gr_scripting.m4 \
+ gr_set_md_cpu.m4 \
+ gr_swig.m4 \
+ gr_sysv_shm.m4 \
+ gr_x86_64.m4 \
+ lf_cxx.m4 \
+ lf_warnings.m4 \
+ lf_x11.m4 \
+ mkstemp.m4 \
+ onceonly.m4 \
+ pkg.m4 \
+ usrp_fusb_tech.m4 \
+ usrp_libusb.m4 \
+ usrp_sdcc.m4
+
+
+# Don't install m4 macros anymore
+# m4data_DATA = $(m4macros)
+
+EXTRA_DIST = $(m4macros) \
+ libtool.m4 \
+ lt~obsolete.m4 \
+ ltsugar.m4 \
+ ltversion.m4 \
+ ltoptions.m4
personal git repositories of Harald Welte. Your mileage may vary