summaryrefslogtreecommitdiff
path: root/gsm-receiver/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gsm-receiver/src/lib/Makefile.am')
-rw-r--r--gsm-receiver/src/lib/Makefile.am96
1 files changed, 18 insertions, 78 deletions
diff --git a/gsm-receiver/src/lib/Makefile.am b/gsm-receiver/src/lib/Makefile.am
index 71ea8fe..a4aa2a6 100644
--- a/gsm-receiver/src/lib/Makefile.am
+++ b/gsm-receiver/src/lib/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2004,2005,2006,2008 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -21,90 +21,30 @@
include $(top_srcdir)/Makefile.common
-SUBDIRS = decoder
-# Install this stuff so that it ends up as the gnuradio.howto module
-# This usually ends up at:
-# ${prefix}/lib/python${python_version}/site-packages/gnuradio
-
-ourpythondir = $(grpythondir)
-ourlibdir = $(grpyexecdir)
-
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
-# -I$(OPEN_BTS_INCLUDES)
-
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(SWIGGRFLAGS) $(WITH_SWIG_INCLUDES) \
- $(WITH_INCLUDES)
-
-ALL_IFILES = \
- $(LOCAL_IFILES) \
- $(NON_LOCAL_IFILES)
-
-NON_LOCAL_IFILES = \
- $(GNURADIO_CORE_INCLUDEDIR)/swig/gnuradio.i
-
-
-LOCAL_IFILES = \
- $(top_srcdir)/src/lib/gsm.i
-
-# These files are built by SWIG. The first is the C++ glue.
-# The second is the python wrapper that loads the _howto shared library
-# and knows how to call our extensions.
-
-BUILT_SOURCES = \
- gsm.cc \
- gsm.py
+grinclude_HEADERS = \
+ gsm_receiver_cf.h \
+ gsm_receiver_config.h \
+ viterbi_detector.h
-# This gets howto.py installed in the right place
-ourpython_PYTHON = \
- gsm.py
+SUBDIRS = decoder
-ourlib_LTLIBRARIES = _gsm.la
+TOP_SWIG_IFILES = \
+ gsm.i
-lib_LTLIBRARIES = libgsmdemod.la
+gsm_pythondir_category = \
+ gnuradio
-# These are the source files that go into the shared library
-_gsm_la_SOURCES = \
- gsm.cc
-
-libgsmdemod_la_SOURCES = \
- gsm_receiver_cf.cc \
- gsm_receiver_config.cc \
+gsm_la_swig_sources = \
+ gsm_receiver_cf.cc \
+ gsm_receiver_config.cc \
viterbi_detector.cc
-# magic flags
-_gsm_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
-
-# link the library against some comon swig runtime code and the
-# c++ standard library
-_gsm_la_LIBADD = \
- $(PYTHON_LDFLAGS) \
- libgsmdemod.la \
+gsm_la_swig_libadd = \
$(LIBOSMOCORE_LIBS) \
- -lstdc++ \
- $(DECODER_LA)
-
-#libgsmdemod_la_LIBADD =
-
-gsm.cc gsm.py: $(LOCAL_IFILES) $(ALL_IFILES)
- $(SWIG) $(SWIGPYTHONARGS) -module gsm -o gsm.cc $(LOCAL_IFILES)
-
-# These headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS = \
- gsm_receiver_cf.h \
- gsm_receiver_config.h
-
-noinst_HEADERS = \
- gsm_constants.h \
- viterbi_detector.h
-
-# These swig headers get installed in ${prefix}/include/gnuradio/swig
-swiginclude_HEADERS = \
- $(LOCAL_IFILES)
+ decoder/libdecoder.la
+include $(top_srcdir)/Makefile.swig
-MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+BUILT_SOURECS = $(swig_built_sources)
-# Don't distribute output of swig
-dist-hook:
- @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
- @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
+no_dist_file = $(swig_built_sources)
personal git repositories of Harald Welte. Your mileage may vary