summaryrefslogtreecommitdiff
path: root/src/lib/decoder/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/decoder/Makefile.am')
-rw-r--r--src/lib/decoder/Makefile.am28
1 files changed, 18 insertions, 10 deletions
diff --git a/src/lib/decoder/Makefile.am b/src/lib/decoder/Makefile.am
index 1ad7899..1726d68 100644
--- a/src/lib/decoder/Makefile.am
+++ b/src/lib/decoder/Makefile.am
@@ -21,28 +21,36 @@
include $(top_srcdir)/Makefile.common
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) -I$(MAIN_INCLUDEDIR)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES)
+
+SUBDIRS = openbtsstuff
noinst_LTLIBRARIES = libdecoder.la
+libdecoder_la_LIBADD = \
+ openbtsstuff/libopenbtsdecoder.la
+
libdecoder_la_SOURCES = \
sch.c \
cch.c \
fire_crc.c \
gsmstack.c \
+ interleave.c \
out_pcap.c \
- tun.c \
- interleave.c
-
-noinst_HEADERS = \
- sch.h \
+ tun.c
+# tch.c \
+# conv.c
+
+noinst_HEADERS = \
+ sch.h \
cch.h \
fire_crc.h \
gsmstack.h \
interleave.h \
- system.h \
out_pcap.h \
tun.h \
- gsmtap.h
-
-# burst_types.h
+ system.h \
+ gsmtap.h \
+ a5-1-2.h
+# tch.h \
+# conv.h
personal git repositories of Harald Welte. Your mileage may vary