summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormeri <meri@e0336214-984f-0b4b-a45f-81c69e1f0ede>2007-04-30 18:39:18 +0000
committermeri <meri@e0336214-984f-0b4b-a45f-81c69e1f0ede>2007-04-30 18:39:18 +0000
commit1870e3694d5ce0a892c839b82520ac00f3ea55f8 (patch)
treeda28c28f4bee42663ca13d5abfe7c9c16a65ce51 /configure.in
parentda107e125605438c7cf739ad34bb6204b3d4b85e (diff)
added win32 support for MINGW32-compiler/cross-compiler
git-svn-id: https://svn.gnumonks.org/trunk/librfid@1989 e0336214-984f-0b4b-a45f-81c69e1f0ede
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index da52275..2411992 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,6 @@ dnl Process this file with autoconf to create configure.
AC_INIT
AC_CANONICAL_SYSTEM
-
AM_INIT_AUTOMAKE(librfid, 0.1.0)
AC_PROG_CC
@@ -11,6 +10,17 @@ AC_EXEEXT
AM_PROG_LIBTOOL
AC_SUBST(LIBTOOL_DEPS)
+AC_MSG_CHECKING([for build environment])
+case "$target_alias" in
+*-mingw*) BUILDENV=WIN32;;
+*-cygwin*) BUILDENV=WIN32;;
+*) BUILDENV=UNIX;;
+esac
+AC_MSG_RESULT($BUILDENV)
+AC_SUBST(BUILDENV)
+AM_CONDITIONAL(ENABLE_WIN32, test "$BUILDENV" == "WIN32")
+AM_CONDITIONAL(DISABLE_WIN32, test "$BUILDENV" != "WIN32")
+
AC_ARG_ENABLE(ccid,
[ --enable-ccid Include internal CCID driver for CM5121],
[MY_CCID=1], [MY_CCID=0])
@@ -52,7 +62,6 @@ AC_ARG_ENABLE(firmware,
AM_CONDITIONAL(ENABLE_FIRMWARE, test "$ENABLE_FIRMWARE" == "1")
AC_ARG_WITH()
-#AC_CHECK_HEADERS(usb.h, [have_libusb="yes"], [ AC_MSG_WARN([usb.h not found, use --enable-libusb=PATH. Otherwise, INDI will compile without Apogee USB support.]) ])
AC_CHECK_LIB(usb, usb_close,,)
AM_CONDITIONAL(HAVE_LIBUSB, test "x$have_libusb" = "xyes")
personal git repositories of Harald Welte. Your mileage may vary