summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorlaforge <laforge@e0336214-984f-0b4b-a45f-81c69e1f0ede>2006-10-14 18:53:50 +0000
committerlaforge <laforge@e0336214-984f-0b4b-a45f-81c69e1f0ede>2006-10-14 18:53:50 +0000
commit6bc8adf40b86195e610f77eed99dc6cd3497936f (patch)
tree785b3d59fdd7b87897e2a3b6502f9dff74a8596d /configure.in
parent36751e15b8ac7a0ed5809385645150ffaaf114d1 (diff)
redesign autoconf/automake infrastructure to support
- building of CM5121 driver (and backends) optional - building of librfid for in-firmware-use git-svn-id: https://svn.gnumonks.org/trunk/librfid@1906 e0336214-984f-0b4b-a45f-81c69e1f0ede
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 31 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index c141be0..d047682 100644
--- a/configure.in
+++ b/configure.in
@@ -11,13 +11,40 @@ AC_EXEEXT
AM_PROG_LIBTOOL
AC_SUBST(LIBTOOL_DEPS)
-AC_ARG_WITH(ccid,
- [ --with-ccid Include internal CCID driver],
+AC_ARG_ENABLE(ccid,
+ [ --enable-ccid Include internal CCID driver for CM5121],
[MY_CCID=1], [MY_CCID=0])
-
# AC_SUBST(MY_CCID)
-AM_CONDITIONAL(MY_CCID, test "$MY_CCID" == "1")
+AM_CONDITIONAL(ENABLE_CCID, test "$MY_CCID" == "1")
+
+AC_ARG_WITH(openct,
+ [ --with-openct Use (patched) OpenCT for CM5121 CCID access],
+ [OPENCT_PATH="$withval"], [OPENCT_PATH=""])
+AC_SUBST(OPENCT_PATH)
+AM_CONDITIONAL(ENABLE_OPENCT, test "$OPENCT_PATH" != "")
+
+AC_ARG_WITH(firmware,
+ [ --with-firmware=PATH Compile for running inside firmware],
+ [FIRMWARE_PATH="$withval"], [FIRMWARE_PATH=""])
+AC_SUBST(FIRMWARE_PATH)
+
+AC_ARG_ENABLE(static,
+ [ --enable-static Don't use dynamic allocations at all],
+ [ENABLE_STATIC=1], [ENABLE_STATIC=0])
+AM_CONDITIONAL(ENABLE_STATIC, test "$ENABLE_STATIC" == "1")
+
+AC_ARG_ENABLE(firmware,
+ [ --enable-firmware Don't use dynamic allocations at all],
+ [ENABLE_FIRMWARE=1], [ENABLE_FIRMWARE=0])
+AM_CONDITIONAL(ENABLE_FIRMWARE, test "$ENABLE_FIRMWARE" == "1")
+
+AC_ARG_ENABLE(reader-cm5x21,
+ [ --enable-reader-cm5x21 Support for Omnikey Cardman 5121/5321],
+ [ENABLE_CM5121=1], [ENABLE_CM5121=0])
+AM_CONDITIONAL(ENABLE_CM5121, test "$ENABLE_CM5121" == "1")
+
+AC_ARG_WITH()
#AC_CHECK_HEADERS(usb.h, [have_libusb="yes"], [ AC_MSG_WARN([usb.h not found, use --enable-libusb=PATH. Otherwise, INDI will compile without Apogee USB support.]) ])
AC_CHECK_LIB(usb, usb_close,,)
personal git repositories of Harald Welte. Your mileage may vary