summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 13993df..8f42d49 100644
--- a/configure.in
+++ b/configure.in
@@ -52,17 +52,13 @@ AC_ARG_WITH(firmware,
[ --with-firmware=PATH Compile for running inside firmware],
[FIRMWARE_PATH="$withval"], [FIRMWARE_PATH=""])
AC_SUBST(FIRMWARE_PATH)
+AM_CONDITIONAL(ENABLE_FIRMWARE, test "$FIRMWARE_PATH" != "")
AC_ARG_ENABLE(static,
[ --enable-static Don't use dynamic allocations at all],
[ENABLE_STATIC=1], [ENABLE_STATIC=0])
AM_CONDITIONAL(ENABLE_STATIC, test "$ENABLE_STATIC" == "1")
-AC_ARG_ENABLE(firmware,
- [ --enable-firmware Don't use dynamic allocations at all],
- [ENABLE_FIRMWARE=1], [ENABLE_FIRMWARE=0])
-AM_CONDITIONAL(ENABLE_FIRMWARE, test "$ENABLE_FIRMWARE" == "1")
-
AC_ARG_WITH()
AC_CHECK_LIB(usb, usb_close,,)
personal git repositories of Harald Welte. Your mileage may vary