summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index dbc608f..ef44e7d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,8 +6,14 @@ lib_LTLIBRARIES = librfid.la
CORE=rfid.c rfid_layer2.c rfid_protocol.c rfid_reader.c
L2=rfid_layer2_iso14443a.c rfid_layer2_iso14443b.c rfid_layer2_iso15693.c rfid_iso14443_common.c
PROTO=rfid_proto_tcl.c rfid_proto_mifare_ul.c rfid_proto_mifare_classic.c
-READER=rfid_reader_cm5121.c rfid_reader_cm5121_openct.c rfid_asic_rc632.c
+READER=rfid_reader_cm5121.c rfid_asic_rc632.c
+
+if MY_CCID
+READER_LOW=ccid/rfid_reader_cm5121_ccid_direct.c ccid/ccid-driver.c
+else
+READER_LOW=rfid_reader_cm5121_openct.c
+endif
librfid_la_LDFLAGS = -Wc,-nostartfiles -version-info $(LIBVERSION) -lopenct
-librfid_la_SOURCES = $(CORE) $(L2) $(PROTO) $(READER)
+librfid_la_SOURCES = $(CORE) $(L2) $(PROTO) $(READER) $(READER_LOW)
personal git repositories of Harald Welte. Your mileage may vary