summaryrefslogtreecommitdiff
path: root/src/gsmd/Makefile.am
diff options
context:
space:
mode:
authorlaforge <laforge@99fdad57-331a-0410-800a-d7fa5415bdb3>2007-08-17 08:33:56 +0000
committerlaforge <laforge@99fdad57-331a-0410-800a-d7fa5415bdb3>2007-08-17 08:33:56 +0000
commitc20bdfa5eafb8ac776092c816018de0b07045c97 (patch)
tree767a45a2e028663afadf78ad563ac0cebb889ea7 /src/gsmd/Makefile.am
parentc5eec553984f937b1f1682378ab7096b7f6b3933 (diff)
Implement GSMD version printout (Matt Mets <matt.mets@cibomahto.com>)
git-svn-id: http://svn.openmoko.org/trunk/src/target/gsm@2727 99fdad57-331a-0410-800a-d7fa5415bdb3
Diffstat (limited to 'src/gsmd/Makefile.am')
-rw-r--r--src/gsmd/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/gsmd/Makefile.am b/src/gsmd/Makefile.am
index 1ff1970..bdb39d0 100644
--- a/src/gsmd/Makefile.am
+++ b/src/gsmd/Makefile.am
@@ -2,6 +2,12 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS = -std=gnu99
plugindir = $(libdir)/gsmd
+gsmd-version.h:
+ echo -e '#ifndef GSMD_VERSION' \
+ '\n#define GSMD_VERSION "'`svnversion`'"' \
+ '\n#endif' > gsmd-version.h
+
+BUILT_SOURCES = gsmd-version.h
sbin_PROGRAMS = gsmd
gsmd_CFLAGS = -D PLUGINDIR=\"$(plugindir)\"
personal git repositories of Harald Welte. Your mileage may vary