summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2013-02-27 19:05:34 +0100
committerHarald Welte <laforge@gnumonks.org>2013-02-27 19:05:34 +0100
commitdd46f418be6a5f7cfc7d0d1e60f83f73edcb7743 (patch)
tree34f68f134973152059474834c08a72f4d7a60fe9 /src/util/Makefile.am
parent821f3af2ac2d77f0f15bdea02c2f3efd0e1cf419 (diff)
add new utility to take GPS and AIS messages and fwd them via UDP
this is useful if you wish to send them into gpsd, e.g.
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 3d87a32..3697358 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -1,7 +1,7 @@
INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS = -std=gnu99
-bin_PROGRAMS = libgsmd-tool cell_log
+bin_PROGRAMS = libgsmd-tool cell_log gps_fwd
libgsmd_tool_SOURCES = libgsmd-tool.c shell.c event.c pin.c atcmd.c \
$(top_srcdir)/src/gsmd/talloc.c
@@ -13,4 +13,9 @@ cell_log_SOURCES = cell_log.c \
cell_log_LDADD = $(top_builddir)/src/libgsmd/libgsmd.la
cell_log_LDFLAGS = -dynamic
+gps_fwd_SOURCES = gps_fwd.c \
+ $(top_srcdir)/src/gsmd/talloc.c
+gps_fwd_LDADD = $(top_builddir)/src/libgsmd/libgsmd.la
+gps_fwd_LDFLAGS = -dynamic
+
noinst_HEADERS = atcmd.h event.h pin.h shell.h
personal git repositories of Harald Welte. Your mileage may vary