summaryrefslogtreecommitdiff
path: root/win32/Makefile.am
diff options
context:
space:
mode:
authormeri <meri@e0336214-984f-0b4b-a45f-81c69e1f0ede>2007-05-02 01:48:44 +0000
committermeri <meri@e0336214-984f-0b4b-a45f-81c69e1f0ede>2007-05-02 01:48:44 +0000
commit64b0ed9cf4f26a0efb85f7547821409ca2e97a9d (patch)
treece5528f3667f39259601ac4cf9769e5fcc4bc95d /win32/Makefile.am
parent855cc21b1a500fa4b8f7ecbc4f745dd7e02b4691 (diff)
updated win32 support for MINGW32-compiler/cross-compiler
git-svn-id: https://svn.gnumonks.org/trunk/librfid@1991 e0336214-984f-0b4b-a45f-81c69e1f0ede
Diffstat (limited to 'win32/Makefile.am')
-rw-r--r--win32/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/win32/Makefile.am b/win32/Makefile.am
new file mode 100644
index 0000000..f565f1f
--- /dev/null
+++ b/win32/Makefile.am
@@ -0,0 +1,15 @@
+LIBVERSION= 0:0:0
+
+noinst_HEADERS = openpcd.h
+noinst_DATA = openpcd.dll
+
+INCLUDES = -I$(top_srcdir)/include
+LIBRFID_DIR = $(top_builddir)/src/.libs/
+CLEANFILES = $(noinst_DATA)
+
+.c.o:
+ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
+
+.o.dll:
+ $(CC) -mno-cygwin --add-stdcall-alias -shared -o $@ -L$(LIBRFID_DIR) $< -lrfid -lwinmm -Wl,-no-undefined -Wl,--entry,__cygwin_noncygwin_dll_entry@12
+ $(STRIP) --strip-unneeded $@
personal git repositories of Harald Welte. Your mileage may vary