summaryrefslogtreecommitdiff
path: root/win32/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'win32/Makefile.am')
-rw-r--r--win32/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/win32/Makefile.am b/win32/Makefile.am
new file mode 100644
index 0000000..f565f1f
--- /dev/null
+++ b/win32/Makefile.am
@@ -0,0 +1,15 @@
+LIBVERSION= 0:0:0
+
+noinst_HEADERS = openpcd.h
+noinst_DATA = openpcd.dll
+
+INCLUDES = -I$(top_srcdir)/include
+LIBRFID_DIR = $(top_builddir)/src/.libs/
+CLEANFILES = $(noinst_DATA)
+
+.c.o:
+ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
+
+.o.dll:
+ $(CC) -mno-cygwin --add-stdcall-alias -shared -o $@ -L$(LIBRFID_DIR) $< -lrfid -lwinmm -Wl,-no-undefined -Wl,--entry,__cygwin_noncygwin_dll_entry@12
+ $(STRIP) --strip-unneeded $@
personal git repositories of Harald Welte. Your mileage may vary